Claim Validation Issue

Incident Report for iSalus Healthcare

Resolved

This incident was resolved as of 12pm on 6/6. For good measures, we did continue to monitor to ensure performance was meeting expectations. If you have any further questions, please contact support
Posted Jun 06, 2025 - 17:06 EDT

Investigating

OfficeEMR is experiencing an issue involving Claim Validations. Clients will see this impact upon reviewing claims ready for processing. We are investigating the issue and will post updates accordingly.
Posted Jun 06, 2025 - 10:13 EDT