iSalus Application Errors

Incident Report for iSalus Healthcare

Resolved

This incident has been resolved and all services are operational. Thank you for your patience.
Posted Sep 23, 2026 - 18:21 EDT

Monitoring

Our team has implemented a fix and is actively monitoring the system. Services are stabilizing, and we’re continuing to monitor performance closely.
Posted Sep 23, 2026 - 18:00 EDT

Investigating

We have received reports regarding some users receiving login and other application errors. Our Engineers are actively investigating this issue. We will provide updates every 15 minutes.
Posted Sep 23, 2026 - 17:40 EDT