The issue with ID.me EPCS has been resolved. We appreciate your patience during this time. Please reach out to support for any further questions/issues.
Posted Nov 18, 2024 - 15:54 EST
Monitoring
Please know the issue with ID.me EPCS has currently been resolved. Our teams will continue to monitor this and provide a final update shortly. We thank you for your patience.
Posted Nov 18, 2024 - 14:00 EST
Update
ID.me continues to resolve the issue. We will provide a final update as soon as possible.
Posted Nov 18, 2024 - 12:41 EST
Update
ID.me continues to resolve the issue. We will provide a final update as soon as possible.
Posted Nov 18, 2024 - 12:03 EST
Update
ID.me continues to resolve the issue. We will provide a final update as soon as possible.
Posted Nov 18, 2024 - 11:24 EST
Identified
ID.me continues to resolve the issue. We will provide a final update as soon as possible.
Posted Nov 18, 2024 - 11:02 EST
Investigating
We have been informed by ID.Me that there is an active issue with sending EPCS. We have ticketed the issue with them, and we will update you as soon as we hear further information on resolution.