Vendor- Atlas Lab Interface Issues

Incident Report for iSalus Healthcare

Resolved

The issue with our Atlas Lab interface has been resolved. All orders and results should now be processing through the system. We appreciate your patience during this time.  Please reach out to support for any further questions/issues.
Posted Mar 20, 2025 - 11:31 EDT

Investigating

We are aware of an active issue with our Atlas Laboratories interface affecting outbound and inbound lab requests. We have ticketed the issue with them, and we will update you as soon as we hear further information on resolution.
Posted Mar 18, 2025 - 12:20 EDT