EMR Template Issues

Incident Report for iSalus Healthcare

Resolved

The issue with EMR templates has been resolved.  We appreciate your patience during this time.  Please reach out to support for any further questions/issues.

**Customer Action Required: If you are still experiencing issues, please log out and close your browser, clear your cache files and try again. We apologize for any inconvenience this may cause.
Posted Mar 21, 2025 - 16:56 EDT

Monitoring

A fix for the EMR templates loading issue has been applied to all customers. We appreciate your patience during this time.  Please reach out to support for any further questions/issues.

**Customer Action Required: If you are still experiencing issues, please log out and close your browser, clear your cache files and try again. We apologize for any inconvenience this may cause.
Posted Mar 21, 2025 - 09:20 EDT

Update

Please know our teams are still actively working to resolve your current issue with EMR templates. We will provide a final update as soon as possible. We thank you for your patience.
Posted Mar 21, 2025 - 08:46 EDT

Investigating

We are aware that there is an issue with EMR templates not loading correctly affecting our customers at this time. Please know our development team is working diligently towards a resolution, and we will provide an update as soon as possible.
Posted Mar 21, 2025 - 07:43 EDT