External- Electronic Faxing Issues
Incident Report for iSalus Healthcare
Resolved
The issue with outbound faxing has been resolved.  We appreciate your patience during this time.  Please reach out to support for any further questions/issues.
Posted Apr 22, 2024 - 15:14 EDT
Investigating
We have been informed by our teams that there is an active issue with outbound electronic faxing. We have ticketed the issue, and we will update you as soon as we hear further information on resolution.
Posted Apr 22, 2024 - 14:08 EDT