OfficeEMR Slowness
Incident Report for iSalus Healthcare
Resolved
The issue with OfficeEMR downtime has been resolved.  We appreciate your patience during this time.  Please reach out to support for any further questions/issues.
Posted Nov 12, 2024 - 14:24 EST
Monitoring
Please know the issue with OfficeEMR slowness and downtime has currently been resolved. We will continue to monitor this and provide a final update shortly. We thank you for your patience.
Posted Nov 12, 2024 - 11:36 EST
Investigating
We are aware that there is an issue with OfficeEMR slowness and downtime affecting all of our customers at this time. Please know our development team is working diligently towards a resolution, and we will provide an update as soon as possible.
Posted Nov 12, 2024 - 11:18 EST