OfficeEMR Billing Issues- Claims, ERAs, Batch Eligibility

Incident Report for iSalus Healthcare

Resolved

The issue with claims, ERAs, and batch eligibility has been resolved.  We appreciate your patience during this time.  Please reach out to support for any further questions/issues.
Posted Feb 14, 2025 - 13:30 EST

Identified

Please know our teams are still actively working to resolve your current issue with claims, ERAs, and batch eligibility. We will provide a final update as soon as possible. We thank you for your patience.
Posted Feb 14, 2025 - 09:03 EST

Investigating

We are aware that there is an issue within OfficeEMR affecting billing functionalities such as claim uploads, ERA downloads, and batch eligibility that is impacting all of our customers at this time. Please know our development team is working diligently towards a resolution, and we will provide an update as soon as possible.
Posted Feb 14, 2025 - 06:59 EST