Intake and MyMedicalLocker Issues

Incident Report for iSalus Healthcare

Resolved

The issue with Intake Cost Estimator Signatures has been resolved. We appreciate your patience during this time.  Please reach out to support for any further questions/issues.
Posted Feb 21, 2025 - 16:40 EST

Monitoring

Please know the issue with intakes and MML Error 500 has currently been resolved.
We are still actively working on resolving a separate intake issue with the Patient Cost Estimator Signatures not saving into OfficeEMR. We will provide a final update shortly and thank you for your patience.
Posted Feb 21, 2025 - 14:35 EST

Identified

Please know our teams are still actively working to resolve your current issue with intake and MML errors. We will provide a final update as soon as possible. We thank you for your patience.
Posted Feb 21, 2025 - 11:16 EST

Investigating

We are aware that there is an issue with intakes and MML receiving error 500 and other connection issues affecting all of our customers at this time. Please know our development team is working diligently towards a resolution, and we will provide an update as soon as possible.
Posted Feb 21, 2025 - 08:32 EST