Intelligent Intake Signature Issue
Incident Report for iSalus Healthcare
Resolved
The issue with intake signatures on iPads has been resolved.  We appreciate your patience during this time.  Please reach out to support for any further questions/issues.
Posted Nov 20, 2024 - 08:15 EST
Monitoring
Please know the issue with intake signatures has currently been resolved. We will continue to monitor this and provide a final update shortly. We thank you for your patience.
Posted Nov 19, 2024 - 20:21 EST
Investigating
We are aware that there is an issue with signatures not capturing on Intelligent Intakes when using an iPad that is affecting our customers at this time. Please know our development team is working diligently towards a resolution, and we will provide an update as soon as possible.

IMPORTANT- Patients may use the 'Type' signature option as an alternative while we work on a resolution. We thank you for your patience with this matter.
Posted Nov 19, 2024 - 13:23 EST